解决安装node-sass错误incompatible with ^4.0.0

React项目中我们在文件中引用sass文件需要安装node-sass

但是俺安装完成后,页面就报了下面的这个错误提示:

incompatible with ^4.0.0

猜一猜都知道,这肯定是版本兼容问题了,解决的办法也很简单,那就是删除当前版本,安装可以兼容的版本。

操作步骤如下:

操作步骤一

删除当前的版本:

npm uninstall node-sass

操作步骤二

安装兼容的版本:

npm install node-sass@4.14.1

如果你使用的是yarn,可以将上面的两行命名替换成如下:

yarn remove node-sass
yarn add node-sass@4.14.1

原创文章,作者:犀牛前端部落,如若转载,请注明出处:https://www.pipipi.net/5428.html

发表评论

登录后才能评论