node-webkit不支持html5播放mp4视频简单介绍

快乐打工仔 分类:实例代码

在当前node-webkit不支持html5播放mp4(以后的情况咱们不敢说),下面就介绍一下如何解决此问题。

出现此种问题的一个很大可能的原因就是mp4的专利版权问题。

解决方案如下:

在本地安装chrome浏览器,进行安装目录(例:c:\Google\Chrome\Application\37.0.2062.103),找到ffmpegsumo.dll文件。

复制(ffmpegsumo.dll)并替换node-webkit目录下的ffmpegsumo.dll。

注:由于chromium 版本众多,所以,下载的chrome浏览器的chromium版本要与node-webkit的chromium版本一致。否则ffmpegsumo.dll文件复制过去也没用。而且还会引起软件崩溃。版本号查看:

Downloads
node-webkit-v0.10.5: (Sep 16, 2014, based off of Node v0.11.13, Chromium 35.0.1916.157): release notes
Linux: 32bit / 64bit
Windows: win32
Mac 10.7+: 32bit / 64bit
网站出售中,有意者加微信:javadudu

回复

我来回复
  • 暂无回复内容